
COURSE OVERVIEW
2025 AGILE TRAINING & COACHING 

LearnMore@AgileDad.Com
1-866-410-1616



SCRUM ALLIANCE CERTIFICATION

AgileDad is proud to offer the following on-
line & live Scrum Alliance Certifications: 

Certified ScrumMaster
Advanced Certified ScrumMaster
Certified Scrum Product Owner
Advanced Certified Scrum Product Owner  
Certified Agile Facilitator
Scrum Essentials
Agile In Sales

STABLE FRAMEWORK CERTIFICATION

We are proud to offer the following Stable 
Framework Accredited Certifications: 

Certified Stable Associate
Certified Stable Process Owner
Certified Stable Master Chief
Certified Stable Scrum Master
Certified Stable Scrum Product Owner 
Certified Stable Hybrid Product Owner 
Certified Stable Software Estimator

TEAM IMMERSION WORKSHOP

This private workshop offers participants a hands-on 
opportunity to experience the entire Agile lifecycle in a 
condensed format, using their actual work. From 
crafting a vision to executing daily activities, all aspects 
of Agile planning are addressed. Participants will learn, 
practice, and master prioritization and estimation 
techniques as a team. Key Agile principles, including 
cadence, communication, and transparency, are 
emphasized and internalized through collaborative 
learning. By immersing themselves in this shared 
experience, teams can accelerate their journey to Agile 
success and achieve outstanding results.

AGILE LEADERSHIP SUMMIT

The success of Agile implementations depends heavily on 
the support and trust of executive leadership and 
management. Executives play a vital role in removing 
obstacles, empowering teams, and inspiring the 
organization to better serve its end consumers. Achieving 
these outcomes requires a shared understanding between 
executives and teams. This summit serves as a forum to 
build a solid foundation of Agile knowledge—both in 
principle and practice. Participants will gain insights into 
setting realistic expectations and learn effective strategies 
to support Agile teams and processes, driving 
organizational success.

AGILE MARKETING CERTIFICATION

Businesses across industries are increasingly adopting 
Agile practices to navigate the societal and economic 
paradigm shifts shaping modern markets. This session 
delves into innovative strategies for meeting customer 
needs, focusing on service and value rather than selling 
at all costs. Participants will gain a deep understanding 
of the differences between Agile marketing and reactive 
marketing, uncovering adaptive approaches to 
campaign management and trust-building with 
customers. Accredited by ICAgile, this course qualifies 
for the ICP-MKG designation, equipping professionals 
with the knowledge and tools to excel in Agile 
marketing.
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AGILEDAD CREDENTIALED COURSES

These courses are designed to maximize the value of 
your learning experience, focusing on actionable skills 
and real-world application. Whether you aim to 
enhance team performance, improve leadership 
abilities, or deepen your Agile knowledge, these award-
winning classes provide everything you need to 
succeed—without the pressure of certification 
requirements.

Agile and Lean Fundamentals
Advancing and Scaling Agile
AI In Agile Application
Agile Leadership Summit
Agile Product Ownership
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Overview

EMPOWERING AGILE TEAMS

The transition from traditional project management 
to a lean Agile approach can be challenging for 
many teams. Adapting to being self-organized, self-
managed, and fully empowered often requires a 
significant shift in mindset and practices. This session 
is designed to help teams navigate the 
organizational transformation that accompanies a 
full transition to Agile. Participants will gain a deeper 
understanding of what to expect, how to embrace 
empowerment, and how to thrive in an Agile 
environment.

PMI CERTIFICATION PREP

We are proud to offer comprehensive 
preparatory sessions for the following PMI-
accredited certifications:

PMI-ACP Test Certification Prep
PMP Test Certification Prep
PMI-PBA Certification Test Prep

Each session is designed to ensure your 
success, providing all necessary materials and 
books. These workshops include a pre-test to 
assess readiness, interactive sessions to 
deepen understanding, and practical 
strategies to help you achieve certification 
with confidence.

Agile Coaching & Mentoring

AgileDad coaches are globally recognized as 
industry leaders, known for their hands-
on approach in helping organizations 
make critical decisions and empowering 
teams to thrive in their Agile journey. We 
stand behind our services with a 100% 
satisfaction guarantee. Coaching is offered in 
flexible buckets of hours that can be used as 
needed, at any level, and never expire. 
For more information, contact  
LearnMore@AgileDad.Com and 
discover how AgileDad coaching can drive 
your success.

All AgileDad training workshops are available in two formats public sessions with a diverse group of students 
or private sessions tailored exclusively for your team. Workshops can be conducted virtually via Zoom or 
delivered live on-site at your company, offering flexibility to meet your specific needs.

AgileDad specializes in creating custom training curriculum tailored to your organizations unique needs. 
These custom programs can be purchased outright or licensed for ongoing use, ensuring your teams receive 
the most relevant and impactful training to drive success.

AgileDad coaches have provided training and coaching at 45 of the Fortune 100 companies, demonstrating 
our proven expertise in driving Agile success. Additionally, our Agile Project Management curriculum is taught 
at many major universities, equipping the next generation of professionals with the skills needed to excel in 
today's dynamic business environment.
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Why 
AgileDad?

About AgileDad: 

At AgileDad, we stand apart as a global leader in Agile certification training and business agility coaching. Our approach is inclusive, pragmatic, and deeply rooted in 
human psychology. Unlike traditional frameworks, we provide actionable tools and strategies tailored to thrive in today's ever-evolving business environment. With 
the rise of remote work and innovative collaboration methods, AgileDad is at the forefront, delivering leadership guidance and customized solutions to help 
organizations achieve true business agility.

We believe agility is not a one-size-fits-all solution. AgileDad embraces a philosophy centered on collaboration and communication, recognizing that every 
organization has unique needs and structures. Instead of applying a cookie-cutter approach, we work with you to design an Agile process that aligns seamlessly with 
your business operations, ensuring more frequent and reliable delivery cadences.

Organizational change requires time, expertise, and skilled guidance. Without it, efforts to adopt Agile can be costly and ineffective. Our mission is to empower your 
team, enabling you to establish an internal Agile Center of Excellence. This foundation provides the tools, knowledge, and confidence for a successful Agile 
transformation. Ultimately, our goal is to make our guidance redundant as your organization becomes self-sufficient in Agile practices.

818 212
AgileDad has hosted over 800 
Public CSM & CSPO workshops.

45

212 Public 
Recommendations on 
AgileDad LinkedIn Profile

99%
AgileDad has provided 
Coaching & Training in 45 of 
the Fortune 100 Companies

99% of AgileDad Students 
pass their certification exam 
after attending a workshop.

AgileDad - Course Offerings   l    Page 4 4



AgileDad - Course Offerings   l    Page  5

AGILEDAD SNAPSHOT

REGISTERED EDUCATION PROVIDER

12,095
AgileDad has certified 

over ten thousand 
ScrumMasters 

through the Scrum 
Alliance

10%
10% of all AgileDad 

earnings are donated 
to local, national, & 
international charity 

organizations

4,865
AgileDad has 

certified over four 
thousand Product 

Owners through the 
Scrum Alliance

20
AgileDad offers 

twenty Agile 
Training workshops 
in addition to our 

world class coaching 
offerings! 

4,926
Agile teams have 

received Agile Coaching 
from AgileDad

23
AgileDad was founded in 

2002. This means we 
have over 23 years of 
Agile Experience to 

share with your 
organization

AgileDad has been recognized as a world class 
training & education provider and has been 
approved by every major accreditation body. 



University - College Brochure    l    Page  10

CO
U

RS
ES

 &
 W

O
RK

SH
O

PS

AgileDad - Course Offerings   l    Page 6  6



About The Agility In Marketing Certification
Agile has taken the world of marketing by storm. 
Businesses of all types are reaching beyond 
technology and leveraging Agile to better understand 
the societal and economic paradigm shifts that are 
causing this shift. This session explores innovative 
ways to better service our customer needs rather 
than selling to them at all costs. You will learn how to
understand the differences between agile marketing 
and reactive marketing to best uncover ways of 
adapting campaigns and building trust with your 
customers. This course has been accredited by 
ICAgile and qualifies for the ICP-MKG Designation.

This session is designed for both new agile marketers 
learning the ropes and experienced marketing teams 
who are trying to re-align or get started on the same 
value generation approach while establishing an 
internal agile marketing focus. This workshop is often 
coupled with Agile Marketing Coaching in order to 
increase the effectiveness and impact.

 Class Logistics: 
〉IC Agile Certified Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included
〉Qualify For Advanced Marketing Workshop

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM 
Agile Marketing Drivers 
And Criticality 

> Defining Agile Marketing
> VUCA For Marketers
> Rapid Pace of Change
> Marketing Anti-Patterns
> Digital Has Changed Marketing

10:15 – 12:00 PM Marketing To Serve 
Vs Marketing To Sell

> Know Your Customer
> Minimal Viable Persona
> Marketing To Sell
> Keeping Sight of Your Customer
> Transactional Marketing

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Defining Agile Marketing

> Being Agile vs Doing Agile
> The Agile Mindset
> Agile Marketing Manifesto
> Losing Prescriptive Practices
> Traditional Vs Agile Marketing
> What Agile Marketers Do Differently

2:30 – 3:00 PM 
Customer Centricity Over
Organizational Focus 

> Customer Centricity Defined
> House Of Cards
> Agile Marketing Case Study
> Using Data & Analytics To Iterate

3:00 – 4:00 PM Focusing On Outcome
Over Output

> Outcome Over Output
> The Marketing Backlog
> Marketing User Stories

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM 
Create A Culture of 
Experimentation & 
Validated Learning 

> Limiting WIP and Flow
> Iterative Development
> Big Bang Campaign Myth
> Iterative Marketing Defined
> Kanban Foundational Marketing

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Making Marketing Work

> Scrum Values & Framework
> The Empirical Process
> Scrum Roles & Accountabilities
> Scrum Events & Artifacts
> The 59 Minute Scrum

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Your Marketing 
Agile Journey 

> Leaders Not Managers
> Agile Marketing Approaches
> Grounded Marketing Decisions
> Scrum, Kanban, & ScrumBan
> Where Do We Start? 
> Agile 12 Step Program

3:30 – 5:00 PM Course Closure 
> Course Review And Questions
> Podcast & Additional Resources
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agility In Marketing Certification
IC Agile Certified Workshop
Instructor: V. Lee Henson CST 
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About The Agile Fundamentals Workshop
One of the most common points of Agile adoption 
failure comes with the incremental on-boarding of 
Agile teams throughout an organization while not 
having everyone starting with the same foundational 
Agile knowledge. This workshop session is designed 
to help everyone on the team learn the fundamental 
principles behind what makes Agile work, and allows 
them to participate in several real world exercises. 
This structure allows everyone on the team to learn
the ‘Why’ behind the ‘How’, and gives everyone a 
chance to leave with the tools needed to effectively 
do their job better. This is a mandatory prerequisite 
to any Advanced or Scaling Agile training session.

 Class Logistics: 
〉AgileDad Credentialed Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included
〉Qualify For Advanced Workshop

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Agile Principles & Values 

> Defining Agile
> Agile Manifesto & 12 Principles
> The Agile Landscape
> Agile vs. Waterfall
> The Scrum Flow Disconnect

10:15 – 12:00 PM Roles & Accountabilities

> Roles Overview
> Agile Leadership
> The POBAFATA Defined
> ScrumMaster Defined
> Self Organized Teams

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Planning & Process

> The Agile Meetings Playbook
> Vision & Strategy
> ART Of The Agile Press Release
> Roadmap Planning
> Defining The Backlog
> Understanding Personas

2:30 – 3:00 PM 
Backlog Item Creation, 
Prioritization, and Estimation

> Priority Defined
> Complexity Defined
> MoSCoW Defined
> Objective Stack Ranking

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Rapid Release Planning 

> Release Defined
> Release Planning Strategy
> Value of Release Planning
> RRP Detailed Instructions
> The Sliding Scale

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Sprint Planning & 
Daily Meeting 

> Definition of Done
> Sprint Planning Details
> Daily Meeting Rules
> Working With Remote Teams
> Agile Reporting

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Review, Demo, 
& Retrospective 

> Sprint Review
> Sprint Demo
> Sprint Retrospectives
> Importance of Limiting WIP
> Dealing With Interruptions
> Podcast & Other Resources

3:30 – 5:00 PM Course Closure 
> Backlog Refinement
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile Fundamentals
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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About Agile Product Ownership Workshop 

Product Owners have the greatest accountability 
when it comes to creating, refining, and maintaining 
the backlog for your product or service. It is a real 
challenge to balance the consumer needs with 
strategic priority and technical benefit.  

The Product Owner is the hub of all communication 
and must be a master facilitator. They are expected to 
work closely with stakeholders, executives, analysts, 
and teams to create a world class product or service. 

In this workshop you will learn all things related to 
product ownership including tips and tricks that can 
only be learned from years of on the ground Agile 
Coaching. Learn with us all of the things that are not 
contained in any published textbook. 

Many have dubbed this workshop Agile 2.0.

 Class Logistics: 
〉AgileDad Credentialed Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included
〉Prepare for Agile Coaching

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Full Agile Landscape 

> Defining Full Agile
> Breakdown of Initiate
> Deconstructing Discovery
> Delivery Execution
> Planning For Release

10:15 – 12:00 PM The Agile Product Owner

> Leadership Engagement
> Breaking Down the POBAFATA
> Roles vs. Titles - Who Cares
> ScrumMaster Magnified
> The Agile Center of Excellence

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM 
Useful Personas 
And Journey Mapping

> Who Is the Target Audience? 
> A Mile In Their Shoes...
> Persona Case Studies
> Understanding the Customer Journey
> Defining Value
> Journey Mapping Examples

2:30 – 3:00 PM 
Vision, Strategy, 
And RoadMapping

> The What and The How
> The Agile Press Release
> Using AI To Assist
> Agile Roadmapping

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Product Backlog Creation 

> Story Composition
> The Business Strategy
> Time vs Relative Complexity
> MoSCoW & The Consumer
> Understanding & Teaching Story Points

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Objective Stack Ranking

> Priority Equals Urgency
> Advanced Story Pointing Techniques
> Time vs Relative Complexity
> OSR Applied
> Understanding The Formula

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Rapid Release Planning 

> Release Defined
> Release Planning Strategy
> Value of Release Planning
> RRP Detailed Instructions
> The Sliding Scale
> Product Owner of Product Owners

3:30 – 5:00 PM Course Closure 
> Backlog Refinement 

Podcast & Additional Resources
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Agile Product Ownership
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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About Advancing & Scaling Agile Workshop
Many Teams and Organizations have been practicing 
Agile for quite some time. and have mastered all of 
the foundational principles. This workshop is 
specifically designed to explore and discuss advanced 
Agile concepts. We will answer the how and why 
behind many Agile techniques and introduce you to 
the parts of Agile that are not discussed in best-
selling books or industry leading videos. 

We will also explore an agnostic view towards scaling 
business agility. Learn what works and where you 
may need to steer clear. The end goal is to focus on 
what is needed in order to create an internal Agile 
Center of Excellence. 

Many have dubbed this workshop Agile 2.0.

 Class Logistics: 
〉AgileDad Credentialed Course
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉
〉

One Year AgileDad Alumni Membership 
Reference Workbook Included
〉Prepare for Agile Coaching

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Full Agile Landscape 

> Defining Full Agile
> Breakdown of Initiate
> Deconstructing Discovery
> Delivery Execution
> Planning For Release

10:15 – 12:00 PM 
Advancing Roles 
& Accountabilities

> Leadership Engagement
> Breaking Down the POBAFATA
> Roles vs. Titles - Who Cares
> ScrumMaster Magnified
> The Agile Center of Excellence

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Managing Technical Debt
and Interruptions

> What is Technical Debt
> Unintentional vs Intentional Debt
> Seven Debts Deep Dive
> Known But Not Resolved
> The Technical Debt Sprint
> The Cost of Interruptions

2:30 – 3:00 PM The Team John Concept
> Laser Focus vs High Performance
> Team John Applied
> Measurable Results
> When NOT To Team John

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Rapid Release Planning 

> Release Defined
> Release Planning Strategy
> Value of Release Planning
> RRP Detailed Instructions
> The Sliding Scale

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Objective Stack Ranking

> Priority Equals Urgency
> Advanced Story Pointing Techniques
> Time vs Relative Complexity
> OSR Applied
> Understanding The Formula

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Scaling Demystified 

> Scaling Techniques
> SAFe Essentials
> LeSS Is More
> Scrum At Scale
> Disciplined Agile Delivery
> When NOT to Scale

3:30 – 5:00 PM Course Closure 
> Backlog Review
> Podcast & Additional Resources
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advancing & Scaling Agile
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 
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About The Agile Leadership Summit

To maximize the effectiveness of Agile 
implementations, it is essential to secure robust 
support and trust from leadership and 
management. Executives are instrumental in 
eliminating barriers, empowering teams, and 
fostering a culture of motivation and inspiration 
throughout the organization, ultimately 
enhancing service delivery to end consumers. 
Achieving this requires a shared understanding 
among executives and across teams. This forum 
is designed to lay a foundational understanding 
of Agile methodologies, encompassing both 
principles and practices, which will be adopted 
by their teams. Through this initiative, 
management will gain insights into expectations 
and learn the most effective methods to support 
their teams in the Agile journey.

This Summit is tailored to cater to three 
distinct audience segments, with each 
segment receiving a schedule designed to 
comprehensively cover topics specifically 
relevant to their respective interests & needs: 

90 Minutes: Designed for up to five CXO 
Executives who are hoping to understand all 
of the essentials behind leading an agile 
organization. (Compare to CAL-E) 

Half Day: Curated for up to 20 leaders, we 
create awareness about the changing 
dynamics in today’s world of work & equip 
leaders with the practices they need to lead 
their teams. (Compare to CAL-T) 

Full Day: Designed to give up to 20 leaders 
full guidance on Agile leadership with 
relevant exercises and examples. (Compare 
to CAL-O)  

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

90 Minutes Agenda Item Details 

30 Minutes What Do I Need To Know
About Agile? 

> The Agile Landscape
> Agile Learning Outcomes
> Importance of Limiting WIP

30 Minutes How Do We Get Started? 

> Getting Started Correclty
> The Agile 12 Step Program
> Data Driven Proof
> Outcome Over Output
> Agile Leadership Alignment

30 Minutes 
How Do We Responsibly 
Scale Agile? 

> 3 Keys to Prepare to Scale
> Leadership Responsibilities
> Executive Agility Focus
> Becoming an Agile Leader
> Open Q&A - Closing

Half Day 

One Hour Agile Approaches & VUCA

> Define VUCA
> Leadership Behaviors
> Cross-Functional Teams
> Organizational Culture
> Leading Without Bias
> Understanding Empiricism

One Hour Leading High 
Performing Teams

> High Performing Team Characteristics
> Team Engagement
> Servant Leadership
> Accountability Culture

One Hour Collaboration For
Multiple Teams

> Scaling Challenges
> Trust & Collaboration
> Team Metrics

One Hour Influence As A Leader > Coaching & Influencing
> Open Q&A - Closing

8:30– 10:00 AM The Context For Agile

> Economic & Market Factors
> Fixed vs Growth Mindset
> The Agile Landscape
> Understanding WIP Limits
> Organizational Vision & Strategy

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Agile Overview

> The Agile Manifesto
> High Performing Teams
> Empirical Process Control
> Agile Methods Defied
> The Agile 12 Step Program

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Leadership In An 
Agile Context

> Servant Leadership
> The Power of The Story
> Leadership Values
> Structure Of An Organization
> Leadership & Governance Policies
> Agile Leadership Case Study

3:30 – 5:00 PM Course Closure 
> Leadership Facilitation Toolkit
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

Agile Leadership Summit
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 

Full Day 



About AI Application In Agile

This one-day AgileDad Credentialed Workshop 
is designed to introduce participants to the 
transformative capabilities of AI as they apply to 
Agile practices, enhancing project management, 
team dynamics, and delivery outcomes.

During this dynamic session, you will dive deep 
into the fundamentals and applications of 
leading AI technologies such as Claude, Gemini, 
Jasper, CoPilot, and notably, ChatGPT-4o. These 
tools are at the forefront of AI innovation, 
offering unique solutions that can streamline 
decision-making processes, automate routine 
tasks, and provide insightful analytics, thereby 
accelerating the Agile workflow and increasing 
project efficiency.

Whether you are a product owner, a scrum 
master, or a team member seeking to 
leverage AI within your Agile environment, 
this workshop will equip you with the 
knowledge and skills needed to effectively 
integrate AI tools into your daily operations. 
V. Lee Henson's expert guidance ensures a 
comprehensive learning experience, with 
practical examples and interactive 
discussions that highlight how AI can solve 
real-world problems in Agile settings.

Harness the power of AI and revolutionize 
your Agile practices. Gain the insights and 
tools necessary to lead your projects and 
teams towards more innovative and 
productive horizons.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 9:40 AM Generative AI Foundations

> Understand Essential Terms
> Explore Various AI Models
> Prompt Writing Explained
> Ethical AI Explained
> Agile & AI Synergy

9:40 – 10:15 AM
AI Product Idea Generation 
and Brainstorming

> AI Generated Product Ideas
> Brainstorming & Communication
> High Level Project Plan Creation
> Key Agile Roles Defined
> API Tool Integrations

10:15 – 10:30 AM

10:30 – 11:00 AM Vision & Strategy Creation

> The Agile Press Release
> The Elevator Pitch
> North Star vs Product Vision
> Product Brand Awareness
> The Question Words
> Help Me Understand

11:00 – 11:15 AM Visual & Contextual 
Roadmapping

> Epic Level Roadmapping 
> Swim-Lane Roadmaps by Quarter
> Contextual Roadmaps
> Visual Roadmapping

11:15 – 11:30 AM Sample Product 
Backlog Creation

> Feature & Story Introduction
> Breaking Down Complex Work
> Backlog Creation & Allocation

11:30 – 12:00 PM Create a Perfect Persona > Persona Identification & Creation
> Visual Empathy Mapping

1:00– 2:15 PM Build Amazing Team 
Working Agreements

> Workplace Culture, Norms, & Standards
> Meeting Templates & Guidelines
> Team Working Agreement Creation
> Communication Styles & Preferences
> Team Sign-Off

2:15 – 2:30 PM Afternoon Break 

2:30 – 3:45 PM Exporting Assets From AI

> Prompts To Export Assets
> Perfecting Export Results
> Validate and Verify Data
> AI Memory Building
> Create A Prompt Library

3:45 – 4:00 PM Afternoon Break 

4:00 – 4:30 PM 
Generating Meaningful 
AI Prompts

> Create a Prompt to Master Prompt
> Teach AI To Ask You FIRST
> Build on Communicative Learning
> Structure Better Prompts
> Leverage AI In Marketing & Media
> Agile AI Case Studies

4:30 – 5:00 PM Course Closure 
> Content Review
> Open Q&A
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

AI Application In Agile 
AgileDad Credentialed Workshop
Instructor: V. Lee Henson CST 

12:00 - 1:00 PM

Morning Break 

Lunch



This workshop is unlike any other you’ve 
attended. It goes beyond theory, offering practical 
insights and solutions to real-world challenges. 
Here’s what makes it stand out:

Practical, Problem-Solving Focus:
While the class is grounded in the Scrum 
Framework and Agile concepts, the focus extends 
far beyond textbook theory. We dive deep into 
solving the pressing problems and challenges 
participants face, making the learning experience 
directly applicable to your work.

More Than Just Test Preparation:
If your sole goal is to pass the certification test, 
this class isn’t for you. While our students 
consistently achieve some of the highest average 
test scores among all trainers, our primary 
objective is to deliver meaningful, actionable 
knowledge that transforms how you work—not 
just help you pass a test.

Scrum for All Industries:
Scrum is no longer confined to software 
development or an all-or-nothing approach. This 
class highlights real-world examples of how 
organizations—ranging from startups to 
enterprises—have successfully adopted Scrum to 
drive dramatic incremental improvements across 
various industries.

 Class Logistics: 
〉Eligibility To Take Scrum Alliance

 Online Practice Test and Test 
〉2-Day Online or In-Person Workshop
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership
〉Reference Workbook Included
〉Qualify for Level 2 A-CSM Certification

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Agile Mindset 

> Define Lean, Agile, & Scrum
> The Agile Manifesto
> Waterfall vs. Agile
> The Five Scrum Values
> The Agile Landscape

10:15 – 12:00 PM Agile Soft Skills

> Psychological Safety
> Radical Candor
> The REAL Three Questions
> The Agile 12 Step Program
> Do We Scrum Yet?

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Roles & Accountabilities 

> Roles Overview
> Executives & Leaders
> The Product Owner Role
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Understanding Scrum Teams

2:30 – 3:00 PM The ScrumMaster Role
> ScrumMaster & The Team
> ScrumMaster & The Organization
> ScrumMaster In The Real World
> ScrumMaster Skills & Attributes

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Scrum Execution 

> Day One Overview
> The 59 Minute Scrum
> Complete Agile Planning
> The Agile Daily Standup
> Morning Reflection

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Scrum Ceremonies,
Estimating, & Forecasting 

> Sprint Planning
> The Daily Scrum
> Sprint Review & Retrospective
> Story Points & Estimation
> Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Definition of Done
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified ScrumMaster
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 
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About The A-CSM Workshop
As a Certified ScrumMaster® (CSM®), you’ve 
gained foundational knowledge of Scrum values, 
practices, and applications, positioning you to 
bring expertise and insights beyond traditional 
project management. However, becoming Agile 
is a lifelong journey. Successfully integrating 
Scrum values and Agile principles into your 
professional environment requires diligence, 
patience, and a steadfast commitment to 
continuous improvement.

The next step in your journey is earning the 
Advanced Certified ScrumMaster™ (A-CSM™) 
certification from Scrum Alliance®. This advanced 
program is designed for CSMs with one or more 
years of experience in the role, offering deeper 
insights and enhanced skills to elevate your 
impact.

Take the next step to refine your expertise, 
expand your capabilities, and solidify your path 
as an Agile leader.

 Class Logistics: 
〉AgileDad University Membership
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership
〉Reference Workbook Included
〉Qualify for Level 3 CSP-SM Course

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Agile & Scrum Overview 

> Presence In Scrum
> The Agile Umbrella
> History of Agile
> The Agile Manifesto
> The Agile Landscape

10:15 – 12:00 PM Agile Facilitation & Coaching

> Divergent vs Convergent Thinking
> Listening Techniques
> Coaching Stance
> Coaching Techniques
> AgileDad University Access

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Roles & Accountabilities 

> Teams vs Working Groups
> Team Technical Practices
> The Product Owner Role
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Definition of Done

2:30 – 3:00 PM The ScrumMaster Role
> ScrumMaster & The Team
> ScrumMaster & The Organization
> ScrumMaster In The Real World
> ScrumMaster Skills & Attributes

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Extended Agile Framework 

> Day One Overview
> Vision & Strategy
> The Agile Press Release
> The Agile Daily Standup
> The Agile Roadmap

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Scrum Ceremonies,
Estimating, & Forecasting 

> Sprint Planning
> The Daily Scrum
> Sprint Review & Retrospective
> Story Points & Estimation
> Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Resolving Impediments
> Scaling Scrum & Agile
> Personal & Professional Development
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advanced Certified ScrumMaster
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

LEVEL ONE CSM & ONE YEAR 
WORK EXPERIENCE REQUIRED 
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About The CSPO Workshop
This workshop offers a truly unique learning 
experience, setting it apart from any other 
training you’ve attended. Here’s why:

Practical, Real-World Focus:
While rooted in the Scrum Framework and Agile 
concepts, this workshop goes beyond theory. We 
take a hands-on approach to address real-world 
challenges, helping participants solve pressing 
issues they encounter in their roles.

More Than Just Certification:
If your only goal is to pass the certification test, 
this is not the class for you. While our students 
consistently achieve top-tier test scores, our 
primary focus is on providing knowledge and 
skills that bring meaningful change to your work 
and organization.

Scrum Beyond Software:
Scrum is no longer confined to software 
development or an all-or-nothing approach. This 
class showcases real-world examples of how 
organizations—from startups to enterprises—
have adopted Scrum to achieve dramatic 
incremental improvements across various 
industries.

 Class Logistics: 
〉Eligibility To Take Scrum Alliance

 Online Practice Test and Test 
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership 
〉Reference Workbook Included
〉Qualify for Level 2 A-CSPO Certification

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Product Owner Role 

> Product Owner Anti-Patterns
> Product Owner Skills /Qualities/ Attributes
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> The Product Owner Conundrum

10:15 – 12:00 PM Working With Stakeholders

> Defining Stakeholder Groups
> Decision Making Approaches
> Facilitator Defined
> Coming To Consensus
> Product Owner Collaboration

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Product Strategy

> Vision & Strategy
> ART Of The Agile Press Release
> Agile Estimation
> Roadmapping & Rapid Release Planning
> Determining Velocity
> Initial Estimates From The PO/TA

2:30 – 3:00 PM The Agile Meetings Playbook
> Total Meeting Overview
> Product Owner As a Facilitator
> Meeting Optimization
> Calling In The RATS

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM 
Customer Research & 
Product Discovery 

> Understanding Roles & Personas
> Product Discovery Techniques
> Product & Feature Ideas
> Product Discovery
> Communicating Ideas

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Testing Product 
Assumptions 

> Sprint Review Meeting
> Advanced Product Discovery
> Assumption vs Hypothesis
> Outcome Over Output
> Defining Value

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM Product Backlog Design 

> Strategic Business Priority
> Time vs. Relative Complexity
> Understanding MOSCOW
> Acceptance Criteria
> Objective Stack Ranking
> Sprint Backlog

3:30 – 5:00 PM Course Closure 
> Backlog Refinement
> Understanding Communication
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified Scrum Product Owner
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 
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About The A-CSPO Workshop
As a Certified Scrum Product Owner® (CSPO®), 
you’ve gained the skills to maximize business 
value and optimize the Product Backlog, 
ensuring you deliver the best possible outcomes 
to satisfy key stakeholders.

The next step in your Agile journey is earning 
the Advanced Certified Scrum Product Owner® 
(A-CSPO®) certification. This advanced course 
builds on your foundational knowledge, 
equipping you with deeper insights and 
enhanced techniques to excel as a Product 
Owner.

You can enroll in the A-CSPO course at any time 
after completing your CSPO certification. To 
receive your A-CSPO certification, you’ll need at 
least 12 months of Product Owner experience 
logged in your Scrum Alliance profile.

 Class Logistics: 
〉AgileDad University Membership
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉Two Year Scrum Alliance Membership
〉Reference Workbook Included
〉Qualify for Level 3 CSP-PO Course

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM The Product Owner Role 

10:15 – 12:00 PM Product Owner Facilitation

> Divergent vs Convergent Thinking
> Listening Techniques
> Coming To Consensus
> Defining Key Terms
> Complete Agile Planning

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Working With Teams 

> 7 Deadly Sins of Technical Debt
> The Agile Umbrella
> Technical Practices
> Product Owner With Multiple Teams
> Feature Vs. Component Teams
> Managing Dependencies

2:30 – 3:00 PM Agility Understood
> Extreme Programming
> Dynamic Systems Development Method
> Feature Driven Development
> Lean & Kanban

3:00 – 4:00 PM Importance of Limiting WIP
> Project & Roadmap Level WIP
> Team WIP Limits & Little's Law
> Individual WIP & Kanban Boards

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Scaling Agile 

> Scaled Agile Framework
> Large Scale Scrum
> Scrum At Scale
> Enterprise Scrum
> Disciplined Agile Delivery

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Developing Practical
Product Strategies 

> The ART of The Agile Press Release
> Business Model, Value Proposition Canvas
> Lean Canvas
> Story Points & Estimation
> Roadmapping & Rapid Release Planning

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Customer Research & 
Product Discovery 

> Product Discovery Techniques
> User Story Mapping
> Cognitive Bias
> Assumption vs Hypothesis
> Outcome Over Output
> Defining Value

3:30 – 5:00 PM Course Closure 
> Enhanced Backlog Creation
> Advanced Product Backlog Refinement
> Personal & Professional Development
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Advanced Certified Scrum Product Owner
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

LEVEL ONE CSPO & ONE YEAR 
WORK EXPERIENCE REQUIRED 

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

> Product Owner Anti-Patterns
> Product Owner Skills /Qualities/ Attributes
> Product Owner In The Real World
> Agile Analysts - POBAFATA
> Understanding Stakeholders & Personas
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About The Certified Facilitator Workshop 
Facilitation is the cornerstone of effective 
collaboration, decision-making, and creativity 
within teams. The Certified Agile Facilitator (CAF) 
course is designed for individuals seeking to 
deepen their facilitation mindset and skills while 
learning from experienced Agile practitioners.

This workshop provides hands-on training to 
develop the expertise needed to guide teams 
toward meaningful outcomes. It’s an essential 
step for those aspiring to become Certified Agile 
Coaches, as facilitation is a critical tool in any 
coach's toolkit.  

 Class Logistics: 
〉AgileDad University Membership
〉2-Day Online or In-Person Workshop 
〉Class Eligible For 16 PDU's or SEU's 
〉2-Year Scrum Alliance Membership
〉Preparation for Agile Coach Certs

Time Agenda Item Details 

8:30 – 9:00 AM Welcome & Agenda 
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

9:00 – 10:00 AM Setting The Stage 

10:15 – 12:00 PM 
Understanding Group 
Context & Needs

> Gaining An Understanding
> The Four Magic Words
> Psychological Safety
> Ethical Facilitation
> Facilitation Preparation Checklists

12:00 – 1:00 PM Lunch - Day 1 

1:00 – 2:15 PM Orientation of a Facilitator

> Facilitator Orientation Defined
> Group Decision Making
> Listening Techniques
> Delivering & Receiving Feedback
> Voice of The Group
> Models For Emotional Intelligence

2:30 – 3:00 PM Facilitating Through Conflict
> Defining Conflict

Hidden Benefits of Conflict
> Five Tips For Maintaining Positivity
> Conflict Resolution

3:00 – 4:00 PM Forwarding The Action
> The Decision Is NOT The End
> Taking Decision Actions Forward
> Walk The Walk

4:45 – 5:00 PM Day 1 Close & Homework > Day 1 Review
> Homework & Dismissal 

Day Two 

8:30– 10:00 AM Facilitation Review

> Personal Inspection & Adaptation
> Event Inspection & Adaptation
> Co-Facilitation - Fusion
> Facilitation Case Studies
> Cohesive Facilitation

10:00 – 10:15 AM Morning Break 

10:30 – 12:00 PM Facilitation Practice

> Introduction & Brainstorming
> Strengths & Techniques
> Role Play & Feedback
> Session Fine Tuning
> Wrap-Up And Reflection

12:00 – 1:00 PM Lunch - Day Two 

1:00 – 3:30 PM 
Facilitation Practice 
Continued

> Facilitation Practice - Preparation
> Assemble a Facilitation Plan
> Facilitation Practice - Demos
> Facilitation Practice - Feedback
> Discover Three improvements
> Agile Does Require Facilitation
>

3:30 – 5:00 PM Course Closure 
> The Agile 12 Step Program 
> Deepening Your Facilitation Skills
> Podcast & Additional Resources
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad,  LLC. 
Orlando, FL | Salt Lake City, UT

Certified Agile Facilitator
Scrum Alliance Certification Workshop
Instructor: V. Lee Henson CST 

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

> Facilitation Defined
> Facilitation Is A Mindset
> The Facilitation Arch
> Why Facilitation?
> Facilitation Is a Different Coaching Stance
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CSA

Class Logistics:
• Eligibility To Take �e CSA Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSA Workshop
This course is the starting point for understanding 
the Stable Framework™ and how it can improve 
performance within an organization.  A Certified 
Stable Associate (CSA) understands the two 
foundational components of Operational Ecellence. 
In addition, they’ll know to apply them using Agile 
and Stable principles. 

CSA’s learn about the seven components of the 
Stable Framework™ and how they can apply these 
to improve Software Development, Operations, 
Implementation, DevOps, DevSecOps, and any 
other area suffering from the Hidden Factory of 
inefficiency.

This workshop promises to be like no other 
1) We dig deep in class and help people solve 
pressing problems and issues they are facing. 
2) If your only goal for taking the class is to pass the 
test, this class is not for you. While my class average
test score sits near the very top of all trainers, this
is not our primary goal. 
3) Stable is not all about software anymore, nor is it 
an all or nothing prospect. This class will point out 
real world examples of how well known 
organizations from startup to enterprise have 
adopted Stable and witnessed dramatic 
incremental improvements.

Are you ready to book this as a 
private course for your group?
Contact us today to schedule
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• Operational Excellence
• Customer Facing Excellence
• Business Process Excellence
• Effects of Agile on the Software Industry
• What causes Unpredictability?
• The “Hidden Factory” Problem
• Poor Quality Costs Grow Exponentially

• Two Types of Quality Management
• Benefits of a Structured Quality System
• How Much $$ Will Stable Save You?
• Seven Framework Steps (1-7)
• Service Register
• Preserving Institutional Knowledge
• Process Asset Matrix
• Process Asset Controls
• Master Chief
• Process Owner
• Servant Leadership
• Review
• Share Takeaways
• Homework & Dismissal

• Future, Present, Past
• Patterned liked a Sprint
• Five Fundamental Principles of Quality
Management

• Kata Cards, SLAM Charts, Models, etc.
• How to Convert an Existing Process
Into a Stable Environment

• What You Should Not Omit

• Dev, Ops, Imp, DevOps, DevSecOps, etc.
• Stable Scrum
• Sprited Simulation Game Enabling
Participants to Experience Stabilty

• Final Thoughts

9:00 - 10 AM

10:00-12:00 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 2:00 PM

3:15 - 4:00 PM

8:30 - 9:00 AM

10:00 - 10:15 AM

2:00 - 3:15 PM

4:30 - 5:00 PM

10:45 - 11:15 PM

2:00 - 4:30 PM

4:30 - 5:00 PM

Operational
Excellence

Understanding the
“Hidden Factory”

Day 1 - Lunch

Quality Framework
Benefits

Introducing The 
Stable Framework™

Day 1 Close & 
Homework

Day 2

Day 2 - Morning Break

Process Tailoring

Day 2 - Lunch

Framework Application

Course Closure

Certified Stable Associate - CSA 

Stable Institute Certification Workshop
Instructor: V. Lee Henson CSFT

Stable Simulation

7 - Systematization

6 - Process Improvement

1:00 - 2:30 PM

5 - Principles of Stability

4 - Core Meetings
3 - Knowledge Domains

2 - Core Roles

1 - Process Asset Library

4:00 - 4:30 PM

11:15 - 12:00 PM

10:15 - 10:45 PM

9:00 - 9:30 AM

9:30 - 10:00 AM
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cspro

Class Logistics:
• Eligibility To Take �e CSPRO Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSPRO Workshop
Any team member performing repeatable process 
steps can be a Certi�ed Stable Process Owner. 
CSPRO’s are responsible for performing their 
repeatable work at an established standard of 
quality. This is accomplished through the use 
of Kata Cards and checkpoints, and a certificate-
based work low process.

This workshop promises to be like no other! 

1) We dig deep in class and help people solve 
pressing problems and issues they are facing. 
2) If your only goal for taking the class is to pass 
the test, this class is not for you. While my class 
average test score sits near the very top of all 
trainers, this is not our primary goal. 
3) Stable is not all about software anymore, nor is 
it an all or nothing prospect. 

This class will point out real world examples of 
how well known organizations from startup to 
enterprise have adopted Stable and witnessed 
dramatic incremental improvements.

Are you ready to book this as a 
private course for your group?
Contact us today to schedule
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• Operational Excellence
• Customer Facing Excellence
• Business Process Excellence
• Customer Champion
• Supplier Champion
• Process Champion

• Business Value
• Customer Value
• Societal Value
• Identifying Our Many Customers
• Tools to Engage Customers Better
•Systems Thinking
• Process Mapping
• Quality Planning, IQA, QA, QC
• Improving Supply Chain Relationships
• Kaizen
• 6 Forms of  Process Improvement (1-6)
• Fake vs. Real Process Improvement
• Share Takeaways
• Homework & Dismissal

• 
• Systems Thinking, P-D-C-A Model
• S.I.P.O.C. Model, S-D-C-A Model
• Four Types of Measurement
• Two Sides to Metrics

• 8 Forms of Waste
• T.I.M. W.O.O.D.S. is NOT your friend!
• Theory of Constraints (T.O.C.)
• Cross-functional Teams

• Process Recovery Models
• Asset Recovery Models
• Root Cause Analysis
• Kata Cards, and Check-points
• Reading List, Final Thoughts

9:00 - 10 AM

10:15-10:20 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 1:30 PM

3:00 - 4:00 PM

8:30 - 9:30 AM

10:00 - 10:15 AM

2:00 - 2:30 PM

4:30 - 5:00 PM

10:15 - 11:15 PM

1:00 - 2:30 PM

4:30 - 5:00 PM

Stable Framework
Review

The Role of a 
Process Owner

Day 1 - Lunch

Understanding Value

What is a Process?

Process Execution

Day 1 Close & 
Homework

Day 2

Process Improvement

Day 2 - Morning Break

2 - Process Metrics

Day 2 - Lunch

Course Closure

Certified Stable  Process Owner - CSPRO
Stable Institute Certification Workshop
Instructor: V. Lee Henson CSFT

1 - Systemitazition

3 - Lean

4 - Flow

5 - Resilience

6 - Durability

11:15 - 12:00 PM

2:30 - 4:30 PM

4:00 - 4:30 PM

9:30 - 10:00 AM

Who is our Customer?1:30 - 2:00 PM
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csMC

Class Logistics:
• Eligibility To Take The CSMC Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSMC Workshop
A Stable Master Chief is the senior person 
responsible for Operational Excellence within 
the group. They are tasked with creating a 
quality environment, and helping Process 
Owners succeed within it. Leadership training 
is critical to succeeding as a CSMC. 

We dig deep in class and help people solve 
pressing problems and issues they are facing. 
2) If your only goal for taking the class is to 
pass the test, this class is not for you. While 
my class average test score sits near the very 
top of all trainers, this is not our primary goal. 
3) Stable is not all about software anymore, 
nor is it an all or nothing prospect. 

Are you ready to book this as a 
private course for your group?
Contact us today to schedule 
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• Operational Excellence
• Customer Facing Excellence
• Business Process Excellence
• Environment Setup & Support
• Individual & Team Support
• Individual & Team Accountability
• Corporate Liaison

• Stable Maturity Model
• Create Various Assets
• Discuss Barriers to Adoption
• Organizational Leadership
• 6 Forms of Influence
• Leadership vs. Management
• Leadershp
• Followership
• Theories of Motivation
• 3 Keys to Leadership Success
• Review
• Share Takeaways
• Homework & Dismissal

• 
• The 6 Leadership Functions
• Critical Success Factors
• Watching out for Imbalances....
• S.T.O.P. Meetings

• You are Unique!
• Creating a Vision Board
• Mentoring Groups
• Your Circle of Friends

• Empowering Your Boss
• D.I.S.C. Personality Profiles
• The Art of Debate
• Group-based Problem Solving
• Reading List, Final Thoughts

9:00 - 10:00 AM

10:15-12:00 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 2:00 PM

3:15 - 4:30 PM

8:30 - 10:00 AM

10:00 - 10:15 AM

2:00 - 3:15 PM

4:30 - 5:00 PM

10:15 - 12:00 PM

1:00 - 4:30 PM

4:30 - 5:00 PM

Stable Framework
Review

The Role of a 
Master Chief

Day 1 - Lunch

Quiality Planning

Leadership

The Stable Framework
Leadership Model

Day 1 Close & 
Homework

Day 2

How to Succeed in
Business

Day 2 - Morning Break

Personal Development

Day 2 - Lunch

Leading Up, Across
& Down

Course Closure

Certi�ed Stable Master Chief - CSMC 

Stable Institute Certification Workshop
Instructor: V. Lee Henson CSFT
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csSM

Class Logistics:
• Eligibility To Take �e CSSM Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSSM Workshop
A Stable Scrum Master is focused on  ensuring the 
team achieves Operational Excellence, which means 
using Agile techniques to deliver precisely what the 
customers what (Effectiveness), and doing so
with minimal waste (Effeciency). 

This workshop promises to be like no other! 

1) We dig deep in class and help people solve 
pressing problems and issues they are facing. 

2) If your only goal for taking the class is to pass the 
test, this class is not for you. While my class average
test score sits near the very top of all trainers, this
is not our primary goal. 

3) Stable is not all about software anymore, nor is it 
an all or nothing prospect. This class will point out 
real world examples of how well known 
organizations from startup to enterprise have 
adopted Stable and witnessed dramatic incremental 
improvements.

Are you ready to book this as a 
private course for your group?
Contact us today to schedule
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• The Need for Agile
• The Agile Manifesto
• Agile Today
• The Artifacts
• The Roles
• The Meetings
• Common Adoption Challenges

• Kata Cards, SLAM Charts
• 5S Improvements, Kaizen Projects
• Additional Questions
• Kanban vs. Sprint Boards
• Lean, WIP,  & Pull Workflows
• Combining Kanban & Sprints
• User Stories, Burn-up Charts
• Information Radiators, Personas
• Cross-functional Teams, Kano Model
• Wire-frames, Kaizen, Automation
• Review
• Share Takeaways
• Homework & Dismissal

• Review of Scrum & Scrumban
• Simulation Overview
• Class Breaks Into Scrum Teams
• Scrum and Scrumban Begin

• Teams use Scrum and Scrumban
princples learned in class to create
complete games for other teams
to play after lunch.

• Playing of games by individuals
from other teams.

• Team Retrospectives
• Retrospective Share with Classmates
• Reading List, Final Thoughts

9:00 - 10 AM

10:15-10:20 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 2:00 PM

3:15 - 4:30 PM

8:30 - 10:00 AM

10:00 - 10:15 AM

2:00 - 3:15 PM

4:30 - 5:00 PM

10:15 - 12:00 PM

1:00 - 4:30 PM

4:30 - 5:00 PM

History of Agile

Scrum

Day 1 - Lunch

Stable Additions
to Scrum

Scrumban

Common Agile 
Fixtures

Day 1 Close & 
Homework

Day 2

Scrum Simulation

Day 2 - Morning Break

Game Creation
(Simulation)

Day 2 - Lunch

Game Playing
& Retrospectives
(Simulation)

Course Closure

Certified Stable Scrum Master - CSSM
Stable Institute Certification Workshop
Instructor: V. Lee Henson CSFT
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csSPO

Certi�ed Stable Scrum Product Owner - CSSPO
Stable Institute Certi�cation Workshop
Instructor: V. Lee Henson CSFT

Class Logistics:
• Eligibility To Take �e CSSPO Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSPRO Workshop
A Scrum Product Owner is the single person 
responsible for the success of the product or 
service being developed.  

This is a big responsibility and requires 
leadership and a solid knowledge of Scrum and 
Stable principles.

This workshop promises to be like no other!
1) We dig deep in class and help people solve
pressing problems and issues they are facing.

2) If your only goal for taking the class is to pass 
the test, this class is not for you. While my class 
average test score sits near the very top of all 
trainers, this is not our primary goal.

3) Stable is not all about software anymore, nor 
is it an all or nothing prospect. This class will 
point out real world examples of how well 
known organizations from startup to enterprise 
have adopted Stable and witnessed dramatic 
incremental improvements.

Are you ready to book this as a 
private course for your group?
Contact us today to schedule
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• History of and Need for Agile
• The Agile Manifesto
• Scrum/ Scrumban/Hybrid Projects
• Stable Additions to Scrum
• Product Backlog
• Product Development
• Corporate Liaison

• 4 Levels of Planning
• The Vision Meeting
• The Release Planning Meeting
• Team Motivation
• Team Dynamics
• Radical Candor
• Stakeholder Identification
• Requirements tools
• Personas
• Lean Canvas Model/Lean Startup
• Review
• Share Takeaways
• Homework & Dismissal

• 
• User Stories/Storyboarding
• Gherkin
• I.N.V.E.S.T.
• Story Points
• Success Profiles
• Analagous Estimates
• Parametric Estimates
• Buttom-up Estimates
• Building U.S.A.M.L. Models
• Task level estimation

• Hands-on learning by example
• Hands-on learning by exmaple

• Reading List, Final Thoughts

9:00 - 10 AM

10:15-10:20 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 3:00 PM

3:15 - 4:30 PM

8:30 - 10:00 AM

10:00 - 10:15 AM

2:00 - 3:15 PM

4:30 - 5:00 PM

10:15 - 12:00 PM

1:00 - 4:30 PM

4:30 - 5:00 PM

Scrum
Scrum-ban
Hybrid Projects

The Role of a 
Product Owner

Day 1 - Lunch

Starting an
Agile Project

Working Together
as a Team

Working with
Stakeholders

Day 1 Close & 
Homework

Day 2

Bahavior Driven
Development (BDD)
Design Thinking

Software Analysis
Design & Estimation

USAML

Day 2 - Lunch

Design Thinking 
Workshop
Estimation Workshop

Course Closure
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csSE

Certi�ed Stable So�ware Estimator - CSSE
Stable Institute Certi�cation Workshop
Instructor: V. Lee Henson CSFT

Class Logistics:
• Eligibility To Take �e CSSE Exam
• 2-Day Online or In-Person Workshop
• Class Eligible For 16 PDU’s or SEU’s
• Two Year Stable Institute Membership
• Reference Workbook Included

About the CSSE Workshop
A Stable Sof tware Estimator is able to convert 
User Stories into a bottom-up estimates using  
the User Story Architecture Modeling Language 
(USAML).  This workshop is recommended for 
developers and Product Owners wanting to 
improve their estimation skills.

This workshop promises to be like no other! 

1) We dig deep in class and help people solve
pressing problems and issues they are facing.

2) If your only goal for taking the class is to pass 
the test, this class is not for you. While my class 
average test score sits near the very top of all 
trainers, this is not our primary goal.

3) Stable is not all about software anymore, nor 
is it an all or nothing prospect. This class will 
point out real world examples of how well 
known organizations from startup to enterprise 
have adopted Stable and witnessed dramatic 
incremental improvements. 

Are you ready to book this as a 
private course for your group?
Contact us today to schedule
training and coaching!

www.StableFramework.org
866-410-1616
LearnMore@AgileDad.com

AgileDad, LLC.  Orlando, FL | Salt Lake City, UT

Time Agenda Item Details

8:30 - 9:00 AM Welcome & Agenda
• Meet Your Insructor
• Meet Your Team
• Course Agenda & Goals
• Has Scrum Helped Estimation?
• Foundatoin Estimatoin Concepts
• Estimation Procedure
• Analysis, Design, Estimation
• Project Tracking
• Operational Excellence
• Continual Improvement

• Scrum
• Scrum-ban
• Hybred Projects
• Removing the Hidden Factory
• Transparnecy
• Preserving Institutional Knowledge
• How we used to do this
• BRD, SRS, SDD
• Analagous Estimates
• Expert Judgment Decomposition

• Review and class disucssoin

• Stakeholder Analysis
• Storyboarding/User Stories
• Definition of Ready
• Definition of Done

• Creating Use Cases from User Stories
• Creating Use Case Data Diagrams
• Using Modles to Improve Diagrams
• Converting Diagrams to Estimates

• Real-world experience estimatinng
projects using BDD + USAML +
Estimation Procedure Kata Cards

• Reading List, Final Thoughts

9:00 - 10 AM

10:15-10:20 AM

12:00 - 1:00 AM

12:00 - 1:00 AM

1:00 - 2:00 PM

3:15 - 4:30 PM

8:30 - 10:00 AM

10:00 - 10:15 AM

2:00 - 3:15 PM

4:30 - 5:00 PM

10:15 - 12:00 PM

1:00 - 4:30 PM

4:30 - 5:00 PM

Foundation Concepts

Getting 
Accurate
Estimates

Day 1 - Lunch

Project
Tracking

Operational Excellence

Legacy
Analysis,
Design,
Estimation

Day 1 Close & 
Homework

Day 2

Behavior 
Driven
Development
(BDD)

Day 2 - Morning Break

User Story 
Architectural
Modeling 
Language (USAML)

Day 2 - Lunch

Estimation Workshop

Course Closure

 

AgileDad - Course Offerings   l    Page  23



Project Management Professional - Test Prep

The Project Management Professional (PMP) 
certification recognizes individuals who excel in 
managing people, processes, and business 
priorities across professional projects. Created 
by the Project Management Institute (PMI)—
the world’s leading authority on project 
management—the PMP demonstrates a 
project manager’s proven leadership experience 
and expertise, regardless of their preferred way 
of working.

To earn the PMP certification, candidates must 
meet specific eligibility requirements and pass a 
rigorous 180-question exam. Designed by 
project leaders for project leaders, the exam is 
rooted in real-life project management 
scenarios, ensuring the knowledge gained is 
practical and applicable.

No prior knowledge or experience is 
required to attend PMP Certification 
Training. 

To qualify for the PMP exam your should 
either have:

High school diploma and Minimum 60 
months/5 years experience leading and 
managing projects within the past eight 
years.

35 hours of project management 
education/training. 

You can also meet this requirement with a 
Bachelor's degree or higher and 36 
months/3 years experience leading and 
managing projects within the past eight 
years.

35 hours of project management 
education/training.

Are you ready to book this as a 
private course for your group? 
Contact us today to schedule 
training and coaching! 

Agenda Item Details 

Welcome & Agenda
> Meet Your Instructor
> Meet Your Team
> Course Agenda & Goals

Course Foundations

> Understand Essential Terms
> Explore Various Models
> PMP Cert Explained
> Qualifications Explained
> Materials Overview

Business Environment
> Strategic Alignment
> Project Benefits & Value
> Org Culture & Change Management
> Project Governance & Compliance
> Business Case Study

Start The Project

> Identify & Engage Stakeholders
> Form The Team
> Build Shared Understanding
> Determine Project Approach
> Business Case Study
> Help Me Understand

Plan The Project
> Planning Projects
> Schedule & Sxcope
> Resources & Budget
> Quality & Risks

Lead The Project Team > Create a Collaborative Environment
> Support & Empower The Team
> Manage Conflict

Project Team Performance > Implement Ongoing Improvements
> Manage Project Changes

Closing The Project / Phase
> Project or Phase Closure
> Benefits Realization
> Knowledge Transfer
> Business Case Study
> Team Sign-Off

Preparing For the PMP Exam
> Formulas To Memorize
> Leverage The PMBOK
> Best Study Practices
> Prep For Test Day
> Additional Details

Practice Test and 
Additional Resources

> Access To Practice Test
> Access To Agile Resources
> Access To The BEST Books
> List of Additional Study Guides
> Helpful Websites
> What To Expect

Course Closure 
> Content Review
> Open Q&A
> Reading List
> Final ThoughtsLearnMore@AgileDad.Com 

866-410-1616

AgileDad, L LC. 
Orlando, FL | Salt Lake City, UT

Project Management Professional - PMP
PMI Certification Test Preparation
Instructor: Mike Berry 
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COURSE CONTENT AVAILABLE WHEN YOU NEED IT

OBSERVE AND REPLICATE REPEATABLE RESULTS 

EDUCATE AT A COMFORTABLE KNOWLEDGE LEVEL

LET AGILEDAD CREATE CUSTOM CURRICULUM & 
COURSEWARE FOR YOUR ORGANIZATION 

AgileDad Creates curriculum designed to help your organization be successful. Our solutions 
can be purchased outright and carry your organization's logo, or can be leased on a per use 

basis. Please contact LearnMore@AgileDad.Com for more information and pricing. 

AgileDad also offers a variety of E-Learning modules! These modules 
are available by subscription only. Contact LearnMore@AgileDad.Com 
for details and pricing. 

• Allow your company to learn from wherever they are.
• Always have the most current Agile teachings at your fingertips.
• Affordable subscription model makes it easy and effective for most organizations.
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• AGILE FOR NON-COLOCATED TEAMS
• BUSINESS ANALASYS & CREATION
• CONTRACTS FOR AGILE PROJECTS
• DEVOPS IN AN AGILE WORKSPACE
• EDUCATION USING AGILE METHODS
• FUNDING MODELS FOR AGILE
• GETTING THINGS DONE WITH AGILE
• HUMAN CENTERED WORKSPACES
• IDENTIFYING & MANAGING TECH DEBT
• JUMPSTART YOUR AGILE PROJECT
• KANBAN & SCRUMBAN FOR TEAMS
• LEAN DESIGN SYSTEMS THINKING
• MAP - BUILDING THE RIGHT THING

Raising 
TheBar!

800+
successful implementations 

$2.8M
avg. cost savings per year

350%
avg. increase in productivity

100%
organizational success

Back in 2007, we were working for an organization that tried to help businesses 
better understand and practice greater agility. Through this work we made a few key 
discoveries. Businesses were fixated on taking what they were currently doing and 
optimizing it instead of seeking out a new and better way to execute. Even if they did 
seek to change, they would often be so embedded in their failing process that they 
would try the new framework for a very limited time and often fall back into their 
previous failing practices. Many of the big consulting firms were enabling this 
behavior by placing coaches into the organization full time to try and manipulate 
their current failing processes in an effort to get the paycheck and not rock the boat.  

This is when I said to myself somebody needs to do something about this. The truth 
needs to be spoken. This is when we met with our very first Fortune 100 CEO where 
after we presented to him he said, “You do realize they are all going to hate you. It is 
not because you are wrong or doing anything that should not be done. It is more 
because at this stage most companies out there are like angry teenagers. They ask 
for the advice, listen to you, and stand strong to tell you that you got it all wrong. 
They are not ready to receive the sage advice you have given them and will often try 
to do the exact opposite to prove a point. I expect you to come in and plant a seed. 
Let us water and nurture it for a time. We will then call you in roughly six months and 
let you know that you were right all along and we are now ready to accept your help 
and coaching.” 

The pattern above has manifest itself at least a hundred times and has often 
repeated itself for greatest emphasis. It became a self-fulfilling prophecy. We would 
enter an organization, present observations, get beat up pretty badly, get thrown out, 
and get invited back to boil the now more polluted ocean months or even in a few 
cases years later. Our goal for AgileDad was to create a company where we keep the 
client list small at any given time, provide world class leadership/team-based training 
& coaching for companies of any size, and be a catalyst for good in the world while 
simplifying and humanizing work. We have since invited many Agile coaches and 
trainers both male and female to join us on this amazing crusade to promote a 
healthy more pragmatic approach to implementing Agile. 

The name AgileDad is a great descriptor of what we do. We are not always 
conventional. We have built an amazing diverse team of individuals who each are 
contributors to the fabric of our story. We are AgileDad

AgileDad Supports Education at All Levels
• AgileDad is proud to partner with major universities to provide world class 

business and project management curriculum.
• AgileDad has sponsored events to help educators at all levels achieve Agile & 

Scrum Certifications to help them be successful in the classroom.
• To learn more, please contact us at LearnMore@AgileDad.Com

• NON-SOFTWARE AGILE IMPLEMENTATION
• ORGANIZATIONAL AGILE TRANSFORMATION
• PROGRAM & PORTFLIO MANAGEMENT
• QUALITY ASSURANCE & AGILE
• RAPID RELEASE PLANNING & AGILE
• SCALING AGILE & STRATEGY
• TEST AUTOMATION & AGILE
• USER EXPERIENCE (UX) & AGILE
• VALUE DRIVEN DESIGN & FOCUS
• WORK IN PROGRESS (WIP) LIMITS
• XP & AGILE INTEGRATED
• YARDSTICKK & OTHER AGILE METRICS
• ZESTFUL AGILE IMPLEMENTATIONS

The AgileDad Name

AGILEDAD MODULES - A-Z AGILE FOCUS
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Can
AgileDad 
Coaching Help 
Your Company?
The AgileDad Coaching approach is different 
and truly unlocks and maximizes your 
potential for Agile Implementation success!

For years many organizations have offered the same type 
and model for Agile Coaching. Your company spends a 
large part of its' budget on bringing in a company that 
plants one coach on the ground and provides you with 
round the clock coaching at a standardized rate whether 
you need that coach there or not regardless of their 
specialty. This is a non-working solution that we have 
found a remedy for. 

We start with an initial assessment of the Agile teams and 
contributors, long-term targets will be set with regard to 
your company’s vision and implementation plan for Agile. 
This includes short-term and long-term plans to help 
teams, ScrumMasters, Product Owners and leaders be 
highly effective by utilizing the AgileDad 12 step coaching 
model. Coaching hours may be used for planning, resolving 
impediments, backlog grooming, mentoring, or anything 
that helps your organization see Agile success. We 
systemically help with the cultural and organizational 
changes needed, process improvement and sustainability 
of those changes . Coaching hours are sold as a bucket of 
hours that never expire so the right coach can help you to 
get Agile started or refined within your organization. The 
goal of the Agile Coach in your organizations to work with 
the organization to develop an Agile Center for Excellence 
for long-term sustainability internally instead of long-term 
dependency on coaching and consulting services. 

Coaching hours are billed at a flat rate and you have the opportunity to utilize that time based on the level of coach needed in 
order to facilitate the type of work that needs to be done. In order to maintain scheduling and coaches sanity, we do enforce 
minimum on-site time-lines that are short in nature and do allow for hours to be used remotely when applicable. This unique 
approach has yielded some amazing results. Do not take our word for it. Here is what a few of our clients have had to say: 

""The great thing about having an AgileDad coach is being able to have an outside perspective to see what we can do to improve. It helps 
identify where are we a little bit off, what is working well and is really helping to improve where it makes sense. It's an investment and 
well worth it." "Some of the first guidance I heard was about team size and how getting to the right team size would improve how 
productive we were in addressing the right priority items. Doubling production by dividing just didn't make sense to me but after we 
got teams to the right size, there are many teams that are now reporting 3 to 4 times the improvement in throughput. It's 
amazing that such a simple concept has made profound impact for our company." "After training and some initial follow-up 
coaching sessions, the office is hyped on this applying-new-knowledge-to-processes, so hooray!""

How is AgileDad Coaching different from the rest? 

• AgileDad sells coaching as a bucket of hours that you can use as needed.
• The bucket of hours NEVER expire!
• All AgileDad Coaching is 100% guaranteed! We will enhance your process!
• AgileDad has Micro-Coaching - The FIRST & only try before you buy!
• MANY qualified references available upon request for your review.

LearnMore@AgileDad.Com
866-410-1616
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Best Training I have ever had! I am 
pleased to add Agile Scrum Master 
Certification to my portfolio 
(including Six Sigma Master Black 
Belt Certification), thanks to Lee's 
training and encouragement. Lee is 
very engaging and keeps the subject 
interesting! I highly recommend Lee 
to individuals and companies for his 
training and motivational 
presentations!

 Dino Marsili - Cisco 

I was privileged enough to be able to take 
CSPO and CSM workshops in 2017. The 
teaching style is hands on and practical. He 
has the ability to create balance between 
the training materials and real life 
application of the information. He is very 
engaging and keeps the students full 
attention and participation throughout both 
courses. He is down to earth and truly cares 
about the students that he is teaching. He 
wants all of his students to be successful in 
their aspirations and this was clear in how 
he lead and interacted with students from 
all walks of life. His class has been a catalyst 
to change for me and I will always 
appreciate learning from him. 
Keri Dunlap - Innovation - Worldpay

I recently completed the Scrum 
Certified Product Owner course under 
Lee's tutelage and realized that he's 
the single best instructor I've had 
during my professional career. Lee has 
the unique ability to transform the 
complex into the manageable and the 
challenging into understandable, all 
while promoting an enjoyable learning 
atmosphere. He can be an invaluable 
human resource for anyone looking to 
fully understand Scrum and take their 
career to the next level.

Chris Errington - Nielsen Company

The AgileDad CSM course was 
undoubtedly one of the most 
interesting and beneficial courses I 
have taken. Not only did the course 
provide great information, but also a 
very fun learning environment that 
made it easy to sit through a two day 
course (which is usually not the case!). 
I would absolutely recommend the 
AgileDad courses to anyone 
interested in learning about Scrum.

Carley Donovan - Salesforce

I have had the wonderful opportunity to 
participate in Certified Scrum Master 
training. The training itself was unlike any 
training I have participated in! Aside from 
being incredibly thorough as it pertained 
to the CSM discipline, it was engaging, 
entertaining and truly hands on. I 
definitely received more than I bargained 
for in a very positive way. The morning 
exercise on the first day created a 
positive synergy with the other 
participants that carried through the 
entire class. I highly recommend Agile 
training and any other Agile or Project 
Management classes in the future. 
Shauna Kay Harris - Delta Airlines

I had the pleasure of attending a Certified 
Scrum master course. I have thought 
technical subjects over the years and 
attended many training sessions and 
courses. This was without doubt one of the 
best i have participated in. He delivered the 
material in a entertaining way, anchored it 
to real world scenarios, explained complex 
areas from a multiple of view points. Was i 
able to pass the exam? Without a doubt, but 
that wasn't really the point for me. If you 
want to learn SCRUM or solidify and 
improve what you do with Agile already 
then I encourage you to seek Lee's course 
out and sign up. 

Mat Young - Dell EMC
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